Error 400 Bad Request "failed_precondition" on Collect to Google sheets

google-sheets
odk-collect
google-drive
#1

1. What is the problem? Be very detailed.
I'm trying to push this form to this sheet on google sheets. The sheet works fine, the form creation is without incident, filling the data is fine, but upon submission, I get this error:

image

2. What app or server are you using and on what device and operating system? Include version numbers.

Using ODK Collect 1.21.2 on my Google Pixel

3. What you have you tried to fix the problem?

I have tried recreating the xml form, loading a survey with NO data (in case it's a field problem), and with tons of data, Same error message on each. I also tried deleting both the spreadsheet and the form, creating new versions of each and uploading fresh from start, same error everytime.

I have made permissions to both files fully open in case it's a permissions issue.

I have also tried deleting all the field headings in the results tab in case there was a problem with the actual saving to the sheet... all to no avail.

4. What steps can we take to reproduce the problem?

As mentioned above, error is the same in all instances. Any submission from the xml mentioned above to that google spreadsheet gives the same error.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

I do successfully upload to google sheets spreadsheets from this version of Collect on a regular basis, so there's something wrong with this specific form... just can't figure out what from the error.

#2

@Grzesiek2010 Can you help here?

#3

I got the same error when I tried to send data to your sheet but everything is fine if I create my own one.
@Amit_Kohli
I think you just copied the link visible in your browser because it ends with: edit#gid=773120038
https://docs.google.com/spreadsheets/d/169qibpJCWgUy-SRtoyvKd1EKwV1nDfM0/edit#gid=773120038

in my case it's similar

but you should create a shareable link: https://youtu.be/GnXwGmhaI9U?t=179

then it looks different and ends with /edit?usp=sharing

1 Like