Launching external apps to populate multiple fields - "Requested application is missing"

1. What is the problem? Be very detailed.

I am trying to use this feature for first time. Using guidelines in docs: https://docs.opendatakit.org/launch-apps-from-collect/#launching-external-apps-to-populate-multiple-fields

I have built my xlsform like this:

and it does not work:


2. What app or server are you using and on what device and operating system? Include version numbers.

ODK collect 1.23.3 Server: https://sandbox.aggregate.opendatakit.org
3. What you have you tried to fix the problem?
I have checked launching the same app with one field and works perfectly

4. What steps can we take to reproduce the problem?
Run a test with your own app with multiple fields.
5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
I wonder if recent changes in field-list could have affected this.
In the past I did some test and it was easy and straightforward.

Hi @Alexander_Torrado

what is that app you are trying to use? Could you attach a link?

Thanks for your prompt answer.
Link to apk file

I rather wanted a link to its page, any doc that shows you can use it in that way?

Sorry I do no understand what do you request. Code lines where we include extras are:

image

Perhaps it would be better if I can test with your test apk to confirm how to populate multiple fields.

Thanks

I'm asking about that app you are trying to start using com.ibasoft.ai.textRecognizer is that your app? If not where I can find it, not just apk file but documentation that confirms you can start one of its activities in that way.

Thanks @Grzesiek2010 . I found out my error. It was subtle: I forgot to erase "ex:" when include in body::intent column
image
Perhaps we should highlight this little difference in documentation to avoid confusion

1 Like

Glad you figured it out, @Alexander_Torrado! Great point about documentation -- I've filed https://github.com/opendatakit/docs/issues/1091 so we don't forget. Feel free to make the change if you have a moment.

@LN I did it in docs. I was not sure about uri_data so I only include ex:prefix.