ODK Central v0.1 Alpha

@Sounay While we don't have a roadmap yet, I'm curious if you had a chance to look over the block 2 release criteria and if you had any feedback on those upcoming features?

For everyone else, @issa has written up some great user documentation at https://docs.opendatakit.org/central-intro to help get you started.

Hi
I would like to try ODK Central in the sandbox version, how do I get a username and password?

Thanks in advance

The process is described at https://docs.opendatakit.org/central-install/#using-the-sandbox. I have sent you an invite.

A post was merged into an existing topic: ODK Central v0.2 Beta

A post was merged into an existing topic: ODK Central v0.2 Beta

I've got issue when load data to Power BI from Central via Odata. The issue related to time conversion but i'm not sure what it is so I take screenshot as attachment.
I put the form on the server https://sandbox.central.opendatakit.org for easily check: lightweight-timestamping-if
DataSource.Error: OData: Cannot convert the literal '2019-02-11T16:04:45.638+07' to the expected type 'Edm.DateTimeOffset'.
Capture1

it looks like the problem here is that whichever version of Collect you are using isn't outputting the correct date format. compare:

2019-02-11T16:04:45.638+07
2019-02-11T16:04:45.638+07:00

this is .. incredibly annoying because this means we now have to explicitly patch this case in central when we see a datetime column, where before we could just plumb the data through untouched.

i will try to have a fix in place for version 0.4, which is releasing relatively soon.

thanks for the report!

1 Like

(also @ggalmazor what became of the standardization work here? is javarosa/collect getting patched at some point in this regard?)

Not sure where this one came from, but just FYI the supported formats going forward are doc'd here

1 Like

yes, and as documented in that file:

JavaRosa doesn’t always use the correct offset format
When the local timezone offset is of multiples of a full hour, it outputs this format:

[HH]:[MM]:[SS].[SSS]±[hh] as in 20:04:16.669+09

Only when the local timezone offset is of odd multiples of half an hour, it uses the format we want to use:

[HH]:[MM]:[SS].[SSS]±[hh]:[mm] as in 20:04:16.669+09:30

We should change JavaRosa to ensure it always adds the minutes fragment in the timezone offset text.

FYI I think it may be here: https://github.com/opendatakit/javarosa/blob/master/src/org/javarosa/core/model/utils/DateUtils.java

 private static String formatTimeISO8601 (DateFields f) {
    ...
    String hrs = intPad(value / 60, 2);
    String mins = value % 60 != 0 ? ":" + intPad(value % 60, 2) :"";
    time += offsetSign + hrs + mins;

ie if on hour it drops the mins off the (date)time suffix. On the surface it appears it could be a quick fix, in of itself, but given its potential impact elsewhere it could require some regression testing...?

1 Like

So far we've solved the issues the doc points out in Aggregate. Next, I think it makes sense to focus on JR and fix the issue you've pointed out about the offset lacking the minutes component.

I think we can start by filing an issue https://github.com/opendatakit/javarosa/issues/404

2 Likes

Just want to follow up and say that @Xiphware has fixed this in JavaRosa and the fix will be in the next version of Collect.

1 Like

great, thanks @xiphware; now maybe in 4-5 years i can delete the ugly hack i put in central :slight_smile:

1 Like

any other ugly hacks we should know about? :grin: [not promising anything mind you...]

1 Like

ha! the other bad one was already removed; our openrosa endpoints no longer check the Date field at all because Collect outputs localized date strings that look like HTTP-dates, instead of actually compliant (ie english language) HTTP-dates. but the fix in our case was just not to check the Date field at all, because we don't care about it.

A post was merged into an existing topic: ODK Central v0.4 Beta

I had the same issue on Ubuntu 18.04. I however noticed the docker-compose@central service file was using /usr/local/bin/docker-compose yet my docker-compose installation was at /usr/bin/docker-compose.

Try to run $whereis docker-compose to identify your docker-compose installation location and modify the service file accordingly.[quote="yanokwa, post:5, topic:13437, full:true"]

systemd which is controlled by systemctl was added in Ubuntu 15. Is there a reason you need to use Ubuntu 14? Can you upgrade to say Ubuntu 16 (the newest LTS)?
[/quote]

Has anyone tried adding smtp credentials from AWS SES? I have encountered multiple errors due to the fact that you also need extra parameters specified e.g. username and password.

Also, the config.json.template file only gives parameters for the transport section only, how can one achieve adding other sections such as authenticators and routers section?

This is the guide AWS provides for adding their credentials to EXIM:
https://docs.aws.amazon.com/ses/latest/DeveloperGuide/send-email-exim.html

@Paul_Mulonzia I'm still stuck with broken custom email server. My IT dept's custom mail server settings work nicely in my other apps, but Central seems to be pretty thorough checking the SSL cert (issue here).
So, +1 for more mail server config parameters!