Periods in a gmail address and error replying to posts by email


(danbjoseph) #1

gmail doesn't care about periods, myemail@gmail.com and my.email@gmail.com both will go to the same place. however i'm registered on the forum as myemail@gmail.com while my "official" email address is my.email@gmail.com and when i reply to a post via email i get:

Your reply was sent from a different email address than the one we expected, so we’re not sure if this is the same person. Try sending from another email address

which i think is related to the above (i've had a similiar issue on list-serves). but if i try and change my registered email address in my forum account settings to include the periods i get:

There was an error changing your email address. The address is already in use by a staged user.

: /


(Yaw Anokwa) #2

This is a complicated problem. It's not just periods, right? Some people use plus addressing (e.g., bob+spam@example.com).

There is a thread at https://meta.discourse.org/t/discourse-creates-new-users-if-dots-are-present-absent-in-google-email-address-when-logging-in-using-google/66151 where the Discourse team explains why this behavior exists and why they won't fix it. The punchline is that Google is doing non-standard things.

There is also a thread at https://meta.discourse.org/t/additional-email-support/59847 where Discourse plans to support multiple email addresses per user. Note this feature isn't well-defined so who knows what form it'll take.

What I can probably do is delete your account with the periods and then change your email address in your primary account. That will probably work and if you want me to give it a go, send me a direct message.

Alternatively, you might be able to use Gmail's send-mail-as option and send it without the periods.


(danbjoseph) #3

just curious. it's a minor occasional annoyance at best. no need for anything drastic like deleting. thanks.