Problems in configuring sync-endpoint on local machine

Hi,
I am trying to setup the odk sync_endpoint according to the steps in odk documentations,

I am using docker toolbox and changed it to swarm mode using the command
docker swarm init

after that I cloned the repository and also ran all the commands successfully

my problem is
1 : where should I mention my hostname and what must it be
It checked the security.properties file but could find security.server.hostname, should I add it myself? -
which I did
2: after deploying the stack using the command
docker stack deploy -c docker-compose.yml syncldap, what should I do next?
From the documentation I must go to http://127.0.0.1 after some 30s which I did but didn't get anything

@rrowlands, @linl33
Please provide some hints to me, I have tried all what I found but to no avail.
Thanks

1 Like

@MirwaisAkrami we are currently in the middle of launching a major revision to how to build sync-endpoint so the documentation is a bit out of date. We hope to have it wrapped up in the next week. In the mean time you should be able to build the "odk/sync-endpoint" image from the opendatakit/sync-endpoint repo. After installing Docker simply type "mvn clean install" and it will create the image "odk/sync-endpoint".

Then follow the instructions on the https://github.com/opendatakit/sync-endpoint-default-setup repo and it should work.

Note:

docker stack deploy -c docker-compose.yml syncldap

is what you run when you complete setting everything up from the "sync-endpoint-default-setup" repo.

1 Like

HI Waylon, Has the major revision launched and has the documentation caught up yet?
I'm trying to configure a standard install of Sync Endpoints on a cloud server. I'm looking at this documentation:
https://docs.opendatakit.org/odk2/sync-endpoint/#odk-sync-endpoint-setup

Thanks,
Fred

The documentation has now been updated on the docs website.

Yaaayy!!!
great, thanks. I know it can be a lot of work.
Fred

1 Like

I configured a new sync endpoint using the standard instructions. I created a server from digital ocean image with Docker 18.06.1~ce~3 on an Ubuntu 18.04 platform.

All seemed to go well until I go to the login screen. None of the default accounts work. I can't get past the login screen:
image

I tried changing the account password. I'm not sure how to troubleshoot this. Any suggestions?

I have checked on this.
Thank you

I get the message: Incorrect username or password.

I am also getting the same error message, though I have created this user in LDAP admin

Incorrect username or password

Any suggestions about how to troubleshoot this issue?

I'm still stuck here.

Could this be an issue with the docker port configuration? or swarm mode?
I had to select an advertise and listen address in docker, and I was not sure how these should be configured. Here is what docker ps looks like:

Note: this is not a local machine as indicated in the thread title.

@fvandyk and @MirwaisAkrami, I was caught by this too. When you are creating the user in the LDAP admin, you need to make sure you add the user to the correct group i.e admin = 500. The memberUid attribute is not added by default, so you will need to add it to each group and then add the use as shown in this screen-shot.

Hope this helps.

George

1 Like

Thanks George!
That is helpful. I was finally able to access this interface.
https//xxx.xxx.xxx.xxx:40000/

Previously, I didn't realize I needed HTTPS. Changing to HTTPS I was able to access the PHP +LDAP +admin interface.

However, I'm getting these 2 message when I try to login with admin:
Unable to connect to LDAP server ldap-service
Error: Invalid DN syntax (34) for user
error Failed to Authenticate to server
Invalid Username or Password.

Thanks!

Fred,

Are you using the full login username i.e "cn=admin,dc=example,dc=org", not just "admin"?

2 Likes

Thanks George!
That did it.
I was not using that full login name. oops! I should have taken the instructions literally.
Thanks for your time--much appreciated.
Fred

Sorry to bump this old question but the part in the original question seems not to have been answered yet:

my problem is
1 : where should I mention my hostname and what must it be
It checked the security.properties file but could find security.server.hostname, should I add it myself?

We have this question about security.server.hostname and also about security.server.port and secureport.

Is the security.properties file the one to be found in ./sync-endpoint-default-setup/config/sync-endpoint? Or is it a different file in some other location?

Thanks very much