Trouble with a recap ID list after a repeat group (calculate type / indexed-repeat calculation function)

#1

What is the problem? Please be detailed.
I've built a survey in which there is a repeat group to enter parcel's ID.
To limit input errors, I created a recap list thanks to the calculate question type with an indexed-repeat "formula" in the calculation column.
I picked up that solution in a training course so I just adapted it to my case.
It worked like that and the xml on the Aggregate server is still fine.
Later, I made changes elsewhere in the survey but with the new xml file, when I type ID's, the survey displayed an emtpy list. So there is a screen with a list, but no values in it.
When the xls has been turned into an xml, there have been warnings about missing label text on this list, but it seems to me I had the same messages for the working xml...

What ODK tool and version are you using? And on what device and operating system version?
1.14.0 or 1.18.2 depending of smartphones. I tried on both versions.

What you have you tried to fix the problem?
I compared with older versions of the xls file, but I find nothing different.
I compared the two xml files (the old one which is working, uploaded from aggregate and the new one which doesn't work) and there are no difference.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

0 Likes

#2

Hmm. There's something odd about the XML files you attached. They don't seem to be valid XML. Could you use a different browser to download them?

0 Likes

#3

Hi,

Thank you for your answer.
I'll try, but both XML files have been downloaded with the same on line tool and browser and one is working and the other not.
I'll keep you informed .

0 Likes