ODK build - drag/drop/clone

odk-build

(Colin) #1

Hi all,

I am using Build on both a Windows machine and a Mac (both Chrome, not the dl'd app). The help pane seems to indicate that 'cloning' a question should be possible - that is, if you drag and drop a question while holding the option key on mac, you will get a duplicate of the question instead. Am I reading that correctly? It would be very helpful, but I'm not getting it work - is there a particular order to clicking, etc.? Or is that a feature that currently works in the browser?


Dragging of Controls (Cloning) does not work (ODK Build)
(Efrhain Louis Pajota) #2

Hi Collin,

I'm having a similar problem right now. It used to work. I already posted a thread about it but still no response from the team. I hope they resolve it right away because that feature saves a lot of time. Cheers!


(Dr. Gareth S. Bestor) #3

FYI Option + drag-n-drop to clone works for me running https://build.opendatakit.org/ under Firefox Quantum (61.0.1) on Mac OS High Sierra (10.13.6).


(Colin) #4

Huh, confirmed Xiphware's post, FF Quantum + Mojave 10.14.2 (also works with FF 59.0.2).
Not working on Chrome or Safari, so maybe a webkit issue?


(Efrhain Louis Pajota) #5

I've been using this feature because it saves a lot of time, just recently, it no longer works.

Is it just me or everybody else is also experiencing it? Thanks for the response

Version 0.3.3, Windows 10


#6

I have also been experiencing this recently. It really saves a lot of time and therefore plead to the team to quickly check on this this us.


(Yaw Anokwa) #7

@Efrhain_Louis_Pajota We haven't made any changes to Build for a while. What, if anything, changed on your side?


(Clint Tseng) #8

it seems like chrome and safari changed something on their end.


(Clint Tseng) #9

i have tracked down the issue here and hope to have a fix released soon.