ODK Central v0.2 Beta

odk-central

(Hélène Martin) #21

I think you already have something running at port 80 on your host machine! lsof -i :80 | grep LISTEN might help you find what it is. Then you can try again after terminating that application.


(Neri David Martinez) #22

Thanks for the reply, and sorry for the delay.
Well i tried to find out what was runing in port 80 but i couldnt find any service...
My local machine is confiigured as LAMP server, perhaps there is something colliding around there.

I will create a VM inside my machine and retry the install Central, i will keep you posted on my results.

Best regards and thanks again, Helene!


(Dr. Gareth S. Bestor) #23

Port 80 is the default HTTP port, ie your webserver. So if you are running a LAMP stack, I'd suggest looking at your Apache service (the 'A' of "LAMP") configuration. You can change Apache to use a different port - eg 8080 is not uncommon - but then you need to be aware that any web client (Firefox, Chrome, ...) you may now have to explicitly specify the port when accessing your web pages; eg http://www.example.com:8080

There's plenty of HOWTOs on the web for how to change the Apache port; eg https://stackoverflow.com/questions/3940909


(Shiva Reddy) #24

I was testing the ODK Central API. This is the response which I get in return when I call following URL:

https://sandbox.central.opendatakit.org/v1/forms/testqr/submissions/3ad91554-720c-43ef-a382-7abaa79398e6

Returned JSON:

{"instanceId":"3ad91554-720c-43ef-a382-7abaa79398e6","xml":"30.3402146 78.0440021 0.0 25.286TtFf55uuid:0c24d8da-3639-4a98-8090-acfc2547e5a2","createdAt":"2018-10-09T09:22:09.055Z","updatedAt":null,"submitter":81}'

Only thing is that the 'xml' attribute does not contain actual XML. I was expecting same XML content which I used to get by calling aggregate API.

Is this a bug or there is some other way to parse the actual data from submissions ?


(Clint Tseng) #25

Hey Shiva:

I think you might be missing the xml because you are viewing the output in a web browser, which tries to treat those tags as HTML. When I make that same request from a command line tool, this is what I get back:

cxlt@Durindana:~$ http get https://sandbox.central.opendatakit.org/v1/forms/testqr/submissions/3ad91554-720c-43ef-a382-7abaa79398e6 'Authorization: Bearer (redacted)'
HTTP/1.1 200 OK
Connection: keep-alive
Content-Length: 614
Content-Type: application/json; charset=utf-8
Date: Tue, 09 Oct 2018 21:16:06 GMT
ETag: W/"266-LZmUnoiMVNYTmVOrmE7bejkjTag"
Server: nginx
Strict-Transport-Security: max-age=31536000
X-Content-Type-Options: nosniff
X-Powered-By: Express

{
    "createdAt": "2018-10-09T09:22:09.055Z",
    "instanceId": "3ad91554-720c-43ef-a382-7abaa79398e6",
    "submitter": 81,
    "updatedAt": null,
    "xml": "<?xml version='1.0' ?><testqr id=\"testqr\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\" xmlns:orx=\"http://openrosa.org/xforms\" xmlns:ev=\"http://www.w3.org/2001/xml-events\" xmlns:odk=\"http://www.opendatakit.org/xforms\" xmlns:jr=\"http://openrosa.org/javarosa\" xmlns:h=\"http://www.w3.org/1999/xhtml\"><GEOMETRY>30.3402146 78.0440021 0.0 25.286</GEOMETRY><text>Tt</text><type>Ff</type><number>55</number><ODKUUID>uuid:0c24d8da-3639-4a98-8090-acfc2547e5a2</ODKUUID></testqr>"
}

(Odil) #26

I cannot establish a connection from Excel to Analyze submissions using OData. Excel says that
"The remote server returned an error: (403) Forbidden."
I'm using my email address and password I used to log into ODK Central.


(Neri David Martinez) #27

Thank for the tip Gareth!!! I will take a look.
Sorry for delaying my reply, but i'm a bit "off-the-grid" here in Guatemala.
Please receive my best regards and thanks again!


(Odil) #29

I could import data from ODK Central to Excel. Seems it was some kind of bug with my MSOffice.
BTW, when linked OData Excel 2019 (with ODK Central v0.3Beta) didn't request any authentication and simply downloaded data from the server to my spreadsheet.


(Clint Tseng) #30

it looks like from a previous post you’d already given Excel your username and password, and Excel remembers that forever, as far as i can tell, and just keeps using it. i’m glad you got it working!